Opened 8 years ago

Closed 8 years ago

#342 closed defect (fixed)

us_fematch crashes with floating data

Reported by: demeler Owned by: gegorbet
Priority: normal Milestone: future
Component: ultrascan3 Version:
Keywords: review Cc:

Description

If using dataset "AnnaPEschoen" from Marius Schmid (U Konstanz) and model AnnaPEschoen.2A675.e1205031240-bd_a1205031244_2DSA_0000099_i01.model I get a crash with the following debug info:

*WARNING* Unable to get rotors for lab ID "2"
The simulated data does not have enough radial points and ends too early!
exiting...

Program exited with code 0376.

demeler@demeler-pc1:~/ultrascan3/programs/us_fematch$ grep "The simulated data does not have enough radial points and ends too early!

I am not sure if the rotor issue is to blame here, if it is, this would likely be user-error. But: The problem is that this output is not generated in a gui fashion, only when run from the command line can this error be seen. The error occurs in us_astfem_math and is causing an exit (-1) at that point which doesn't give the GUI a chance to capture the error and display it in a meaningful way. Maybe we need to better catch errors and relay them to the user.

Secondly, we should fix the error - since this is floating data it is possible that there is an issue with the finite element simulation. I used s-values -30 - + 10 for a first try. The good news is that we now have some floating data for testing :-)

Change History (2)

comment:1 Changed 8 years ago by gegorbet

  • Keywords review added
  • Status changed from new to assigned

The actual problem traces to a negative buoyancy value which derives from a Vbar value greater than the reciprocal of density of water at 20 degrees (i.e., a Vbar greater than around 1.0).

The immediate fix for the user is to click on the Solution button and then open the analyte dialog in which he (at least, temporarily) lets the Vbar value be recalculated by clicking on Manage Sequence and then hitting Accept. Note that neither Analyte nor Solution need be saved to Accept them for a specific run (2DSA or FeMatch).

Code changes were made to the Analyte GUI and to both 2DSA and FeMatch to warn the user when the buoyancy value has gone negative and to disallow 2DSA/FeMatch processing until the value is changed so that buoyancy is positive. This ticket is review-ready.

comment:2 Changed 8 years ago by demeler

  • Resolution set to fixed
  • Status changed from assigned to closed

I have tried fitting with floating data - it works now. We will need to revisit this when custom grids are available. Ticket can be closed.

Note: See TracTickets for help on using tickets.