Opened 8 years ago

Closed 8 years ago

#327 closed defect (fixed)

Saving SVG file of residuals results in runtime error and crash

Reported by: dhalling Owned by: gegorbet
Priority: normal Milestone: future
Component: ultrascan3 Version:
Keywords: review Cc:

Description

I cannot save SVG files for residuals for SV date in the FE element viewer. The same error occurs with the noise fitting FE window when I try to save the residuals there instead.
I have been able to save the fitted data as an SVG file.
Most of the time I get this error:
"Microsoft Visual C++ Library
Runtime error
Program: C:\Program Files\ultrascan3\bin\us_fematch.exe
The application has requested Runtime to terminate in an unusual way. Please contact the application's support team for more information."

Change History (4)

comment:1 Changed 8 years ago by gegorbet

  • Owner changed from bdubbs to gegorbet
  • Status changed from new to assigned

I am not able to duplicate the reported behavior on the VM of Windows Vista that I run from my computer. In the FE Model Viewer, I can Save Data and get a proper SVG plot of the residuals, as well as the other plots. If I directly save a plot via the SVG button on the plot itself, I also get a proper SVG file. In neither case does a crash or error report occur.

This ticket needs testing on other Windows installs.

comment:2 Changed 8 years ago by gegorbet

The best way to save plot files in FE Model Viewer is to click on the main window Save Data button. This will save all plots - including the residuals plot - in their appropriate formats. For residuals, the best format is PNG, since it is essentially a raster file, not a vector file.

If you manually try to save a residuals plot as an SVG, using the SVG plot button, you will get a hugely inefficient file. SVG is a vector format. The residuals is a set of dots, so each dot is represented in SVG as a very short "line". In one test case I ran, the PNG version was 13 KB, while the SVG was 67 MB. I could not reproduce a crash, but Borries was able to in certain cases. I believe those case are bugs in the Windows version, but related to a process that you should not really attempt. Stick with use of the Save Data button to save plot files.

comment:3 follow-up: Changed 8 years ago by gegorbet

  • Keywords review added

UltraScan version 1239 has modifications to plotting that should address problems with both Save Data behavior and manually saving an individual plot.

Applications now more properly preserve plot settings when saving plots and other data files. Plots that are saved as SVG format are also saved as PNG. The PNG version of plots is now what is presented in the Report Generator, meaning fonts and scales are preserved.

All plots now have both an SVG and a PNG button. The SVG button can be used with vector plots, but PNG should be used with raster plots, such as the residuals scatter plot.

Review-ready.

comment:4 in reply to: ↑ 3 Changed 8 years ago by demeler

  • Resolution set to fixed
  • Status changed from assigned to closed

Replying to gegorbet:

UltraScan version 1239 has modifications to plotting that should address problems with both Save Data behavior and manually saving an individual plot.

Applications now more properly preserve plot settings when saving plots and other data files. Plots that are saved as SVG format are also saved as PNG. The PNG version of plots is now what is presented in the Report Generator, meaning fonts and scales are preserved.

All plots now have both an SVG and a PNG button. The SVG button can be used with vector plots, but PNG should be used with raster plots, such as the residuals scatter plot.

Review-ready.

I checked this modification and it works as advertised. Will close the ticket.

Note: See TracTickets for help on using tickets.