Opened 8 years ago

Closed 8 years ago

#302 closed defect (fixed)

Mac version not saving newly converted/edited data to DB successfully

Reported by: dzollars Owned by: dzollars
Priority: normal Milestone: future
Component: ultrascan3 Version:
Keywords: review Cc:

Description

As reported by Randy Carney, the Mac user successfully tests and sets up the DB connection. Then when converting legacy data and creating an edit profile, the DB save fails producing a MySQL error. However, the user can go into Local mode, select the data, and then when saving it change to DB mode and save it to DB successfully. While this workaround sidesteps the problem, it is not the way it's supposed to work.

This problem is not observed on the Linux or Windows versions, only the Mac version.

Change History (4)

comment:1 Changed 8 years ago by dzollars

  • Status changed from new to assigned

The error I'm getting in the MAC version is this:

Database returned the following error:
US_DB2 error: could not connect
MySQL error: MySQL server has gone away

I get this when trying to select a project, though I am clearly accessing the database in all the other utilities.

Steps to reproduce, assuming DB is set up correctly:

  1. Open us
  2. Database/Manage? Projects
  3. Select DB mode if not already selected

Does this describe the behavior in this ticket?

comment:2 Changed 8 years ago by dzollars

The mac part of local.pri.template did not specify where mysql include files or libraries are to be found, nor did it link a particular mysqlclient library in. The environment I was using had a local.pri file with the same problem, and it did appear that I was drawing different versions in from multiple places. I compiled a later version of mysql and specified where to find it and these problems went away.

Also, I have made a small change in the way shared memory is allocated. Now if shared memory is in short supply and has been exhausted it just returns without trying to create more. The DB issues were masking this because database information is stored in the shared memory too.

comment:3 Changed 8 years ago by dzollars

  • Keywords review added

comment:4 Changed 8 years ago by dzollars

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.