Opened 8 years ago

Closed 8 years ago

#301 closed defect (fixed)

Edited data crashes program when loaded

Reported by: demeler Owned by: gegorbet
Priority: normal Milestone: future
Component: ultrascan3 Version: 2.0
Keywords: review Cc:

Description

Please attempt to load run "spherical_gold_nanoparticles_in_water/" from database "uslims3_US3_DEMO" (stored under my name).

It crashes any program trying to load it. I suspect that the reason may be that the buffer I used does not contain an analyte. This particular sample will be fitted for the density, so there is no need for an analyte in the solution. Can you please verify that this occurs on someone else's computer and then properly handle whatever error is caused by loading these data.

Change History (2)

comment:1 Changed 8 years ago by gegorbet

  • Keywords review added
  • Status changed from new to assigned

The actual problem was that the number of scans differed from triple to triple. In doing a least-squares fit of omega-squared and time values for all scans of all datasets, the program allocated an array equal to the total number of scans. It essentially used count=number-data-sets * scan-count-dataset0 . This has been fixed so that the total count is the actual sum of scan counts for all data sets.

A fix has been committed. Ticket is review-ready.

comment:2 Changed 8 years ago by dzollars

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.