Opened 9 years ago

Closed 9 years ago

#258 closed defect (fixed)

Changing vHW plot configuration causes program to crash

Reported by: Sarah.Swygert@… Owned by: gegorbet
Priority: normal Milestone: future
Component: ultrascan3 Version: 1.0
Keywords: review Cc:

Description

Changing the configuration of vHW distribution plots usually causes the program to crash, especially if multiple changes are made. (Revision 1125)

Change History (5)

comment:1 Changed 9 years ago by gegorbet

  • Owner changed from bdubbs to gegorbet
  • Status changed from new to assigned

By "distribution plots", you do mean the separate dialog plots that are either distributions or histograms, right? By "configuration", you mean parameters such as smoothing or sensitivity or hide histogram or hide envelope; right?

Does this happen on a Windows version? or Unix? Please describe a little bit about the input data and the nature of plots shown before the crash.

comment:2 Changed 9 years ago by gegorbet

After test runs and study of the source, my understanding of the issues here are as follows.

  • In attempting to modify plots (in any application, not just vHW), clicking on Config leads to a dialog wherein any of the Update * Axis functions can cause a crash.
    • Changing scales in the Axis dialog and clicking Apply can be done multiple times with no problem.
    • The problem comes once the Close button is clicked in the Axis dialog. From the Config dialog, clicking any Update * Axis button afterwards causes a crash.
    • No other Config dialog elements seem to cause a problem.
    • The cause for the Update*Axis re-use crash has been identified in the source and can be easily fixed.
  • In vHW specifically, the Distribution/Histogram/Envelope plots always have a sedimentation coefficient ("s") minimum of zero.
    • This is no particular problem if the s maximum is in single digits.
    • For s maxima in double digits and beyond, the range is too broad, causing insufficient resolution with bunching of values at the end.
    • The fix for this is to use a plot X minimum closer to the actual s minimum present in the data.

comment:3 Changed 9 years ago by gegorbet

This problem is not unique to vHW plots. Any time a plot Config action opened an Axis Configuration and later tried to re-select any Axis Configuration in the dialog, the application would crash.

This has been fixed.

Review-ready.

comment:4 Changed 9 years ago by gegorbet

  • Keywords review added

comment:5 Changed 9 years ago by dzollars

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.