Opened 9 years ago

Closed 9 years ago

#218 closed defect (fixed)

us_fematch - cannot load noise files

Reported by: demeler Owned by: gegorbet
Priority: normal Milestone: 1.0
Component: ultrascan3 Version: 1.0
Keywords: review Cc:

Description

Some change caused noise files to be inaccessible in fematch - please investigate. For example, I cannot load the noise files in demo1_veloc stored under my name in CAUMA3

Change History (4)

comment:1 in reply to: ↑ description ; follow-up: Changed 9 years ago by gegorbet

  • Version set to 1.0

Replying to demeler:

Some change caused noise files to be inaccessible in fematch - please investigate. For example, I cannot load the noise files in demo1_veloc stored under my name in CAUMA3

I was able to load the model (CAUMA3:demeler) and, when I did, the noise loader presented the associated noise. Are you using the latest build of US libraries?

comment:2 in reply to: ↑ 1 Changed 9 years ago by demeler

Replying to gegorbet:

Replying to demeler:

Some change caused noise files to be inaccessible in fematch - please investigate. For example, I cannot load the noise files in demo1_veloc stored under my name in CAUMA3

I was able to load the model (CAUMA3:demeler) and, when I did, the noise loader presented the associated noise. Are you using the latest build of US libraries?

Yes, I was using the latest version. I can replicate the problem on both home and office computer. I realize now what the problem is: When you load a model that was performed with ti and/or ri fitting, then the model loading correctly offers all the noise files for loading. However, when I performed a GA analysis, I loaded the previously calculated noise in the LIMS and had those noise files subtracted from the raw data when it was fitting the GA model. However, when I wanted to display the results, I was unable to subtract the noise files from the raw data and display the GA results that were fitted to the noise-subtracted data. When I loaded the GA model (which of course was done without ti/ri noise fitting, since the noise was already available from a previous 2DSA fit), us_fematch never offered any noise files for subtraction. So I think the problem is related to whether the fit was done with or without noise fitting. If it was done without noise fitting, none of the noise files are presented. To check, load the GA fit:

demo1_veloc.2A260.e1105190813_at05280900_GA_000054_i01.model

and you will see that no noise files can be loaded.

comment:3 follow-up: Changed 9 years ago by gegorbet

  • Keywords review added
  • Status changed from new to assigned

The latest commit includes a fix so that models-with-noise are presented, even when a loaded model does not, itself, have associated noise.

Review-ready.

comment:4 in reply to: ↑ 3 Changed 9 years ago by demeler

  • Resolution set to fixed
  • Status changed from assigned to closed

Replying to gegorbet:

The latest commit includes a fix so that models-with-noise are presented, even when a loaded model does not, itself, have associated noise.

Review-ready.

Yes, I do get the option to load noise for non-noise-associated models now, thanks! Will mark as fixed.

Note: See TracTickets for help on using tickets.