Opened 9 years ago

Closed 9 years ago

#216 closed defect (fixed)

Problem with registration for Ultrascan III build 1050 WindowsXP beta

Reported by: wenta Owned by: bdubbs
Priority: major Milestone: 1.0
Component: ultrascan3 Version:
Keywords: Cc: wenta

Description (last modified by bdubbs)

I have successfully registered for a USLIMS III instance. But it was so far impossible to register the !Ultrascan software. Entered all the required information and received an email; I followed the activation link and clicked on it and got "Thank you... Your UltraScan III license has been previously activated. Please restart UltraScan to retrieve your license.". Then I clicked "Finish Registration" in my Ultrascan3 Registration window and got "Update Error 6---". I have tried copying the Ultrascan3 folder from C:\Programme to C:\Program Files", but this also didn't help. Reinstallation into C:\Program Files also didn't help. The other program modules (ie usedit.exe) also don't work without registration.

Change History (22)

comment:1 follow-up: Changed 9 years ago by wenta

Another problem occured when I tried to install the same Ultrascan version on my office computer: After sending the registration form, I didn't even receive an email. I have checked the Windows firewall, it was turned off.

comment:2 in reply to: ↑ 1 Changed 9 years ago by wenta

Replying to wenta:

Another problem occured when I tried to install the same Ultrascan version on my office computer: After sending the registration form, I didn't even receive an email. I have checked the Windows firewall, it was turned off. This time I get "Update Error 7-99".

comment:3 Changed 9 years ago by bdubbs

The DB shows that you sent registration information three times and successfully answered the email to complete the registration twice. There is also an entry from
Wed Jun 15 2010, os linux, version, 0.1.

The system us sending an http message to http://ultrascan.uthscsa.edu/update-license.php

This should return your license key:

Error 6 indicates that the validator received data, but there was either a DB connection error or that the email address was not in the DB

Error 7 indicates that the email was not validated.

What I can do is remove all your entries and let you start over. You will also need to edit the Windows registry to remove any US3 configuration it saved. You need to run regedit and go to:

HKEY_CURRENT_USER\Software\Ultrascan3

and use the Del key to remove any information saved. Let me know and I'll remove the old registration entries.

comment:4 follow-up: Changed 9 years ago by bdubbs

  • Status changed from new to assigned

comment:5 in reply to: ↑ 4 Changed 9 years ago by wenta

  • Cc wenta added

Replying to bdubbs:
I have it working now. BUT: At first I have tried entering exactly the same data as before, received the email (nikola.wenta@…) and followed the link. The ID was the same: 35512. But finishing registration didn't work in ultrascan. Then I deleted the registry key and entered the data again, slightly different:

  • Institution: UoN School of Biomedical Sciences (before I entered: University of Nottingham, School of Biomedical Sciences);
  • Adress: QMC (before: Queen's Medical Centre);
  • Phone: 00441158230298 (before: 0044115-8230298).

Then I received another email to another email account: nikola.wenta@… (ID 196577), followed the link, finished registration and restarted Ultrascan III. This time it worked.
What I think is that either you are not allowed to put "," or "'" or "-" anywhere in the registration; particularly the "-" in the telephone number might have been the cause for my problem. I guess that I can use the same registration data and enter it into another ultrascan III registration (in my office this time), right?

comment:6 follow-up: Changed 9 years ago by wenta

I can't get it working on my office computer. Maybe there might be a problem with proxy settings or the university firewall? I have tried everything that was working for my home computer: avoiding special characters, changing email adress, deleting registry key, de-/reinstall, but obviously I still don't receive any emails, no matter what email adress I enter. Bruce, can you have a look if there are any new registration attempts from a yahoo adress or nottingham.ac.uk? Definitely please keep the registration for ID 196577 from googlemail.com as this one at least is working for my home computer.

comment:7 in reply to: ↑ 6 ; follow-up: Changed 9 years ago by demeler

Replying to wenta:

I can't get it working on my office computer. Maybe there might be a problem with proxy settings or the university firewall? I have tried everything that was working for my home computer: avoiding special characters, changing email adress, deleting registry key, de-/reinstall, but obviously I still don't receive any emails, no matter what email adress I enter. Bruce, can you have a look if there are any new registration attempts from a yahoo adress or nottingham.ac.uk? Definitely please keep the registration for ID 196577 from googlemail.com as this one at least is working for my home computer.

Niko, can you please copy the complete error/response message into this ticket when you try to register? There should be a message printed on the screen when you submit from work - we need the entire message. Thanks.

comment:8 in reply to: ↑ 7 ; follow-up: Changed 9 years ago by wenta

Replying to demeler:

Replying to wenta:

I can't get it working on my office computer. Maybe there might be a problem with proxy settings or the university firewall? I have tried everything that was working for my home computer: avoiding special characters, changing email adress, deleting registry key, de-/reinstall, but obviously I still don't receive any emails, no matter what email adress I enter. Bruce, can you have a look if there are any new registration attempts from a yahoo adress or nottingham.ac.uk? Definitely please keep the registration for ID 196577 from googlemail.com as this one at least is working for my home computer.

Niko, can you please copy the complete error/response message into this ticket when you try to register? There should be a message printed on the screen when you submit from work - we need the entire message. Thanks.

I get "Update Error 7-99" (after a long while) or simply nothing else happens. I don't receive any registration emails, so no link to follow, so no chance to make "finish regstration" work.

comment:9 in reply to: ↑ 8 ; follow-up: Changed 9 years ago by bdubbs

  • Priority changed from blocker to major

Nike, I spent a bit of time checking and instrumenting the registration code today. It should handle special characters now. Would you please check it out again. Setting up a new system or renewing an old one should both work. If there is still a problem, we should have a record of what happened.

Let me know.

comment:10 Changed 9 years ago by bdubbs

  • Milestone changed from beta to 1.0

comment:11 in reply to: ↑ 9 Changed 9 years ago by wenta

Replying to bdubbs:

Nike, I spent a bit of time checking and instrumenting the registration code today. It should handle special characters now. Would you please check it out again. Setting up a new system or renewing an old one should both work. If there is still a problem, we should have a record of what happened.

Let me know.

Registration is working and now accepts special characters ( , ' - ) in any field (even phone number), but no (german) umlauts ( ä ö ü ß ). There should be a hint in the registration window that umlauts are not supported.
Also, the reply email contains only the email adress:
First Name :
Last Name :
Institution:
Address :
City :
State :
Zip :
Phone :
email : nikola.wenta@…
License : academic
Platform : intel
OS : win32
Version : Pre-Beta

This makes it quite difficult to use exactly the same registration data on another computer. Well, I am not sure if, once slightly different registration data is entered on another computer, the fact that the same email adress was used in both cases, is sufficient to activate usIII on the other computer as well (leaving the activation on the "original", first, computer working), or if the first installation would need a new registration. Therefore I think that the reply email should contain all entered data (as it did when I registered usIII yesterday on my home computer).
I guess, we are already very close to get the registration process working perfectly :-)

comment:12 follow-up: Changed 9 years ago by bdubbs

The blank info is an error. I see you made 24 attempts! The umlauts should have been accepted. It looks like they were in the DB.

I just tested the email and I got a full set of info in the email.

I deleted your registration where you used the googlemail account. Would you please test again (once) using that email and put in exactly one umlaut character. Let me know exactly what error messages you get, if any, and if the email still shows blank entries.

Be sure to run regedit and delete the HKEY_CURRENT_USER\Software\Ultrascan3 entry first.

comment:13 in reply to: ↑ 12 ; follow-up: Changed 9 years ago by wenta

Replying to bdubbs:

The blank info is an error. I see you made 24 attempts! The umlauts should have been accepted. It looks like they were in the DB.

I just tested the email and I got a full set of info in the email.

I deleted your registration where you used the googlemail account. Would you please test again (once) using that email and put in exactly one umlaut character. Let me know exactly what error messages you get, if any, and if the email still shows blank entries.

Be sure to run regedit and delete the HKEY_CURRENT_USER\Software\Ultrascan3 entry first.

I have used my googlemail adress and a umlaut in my last name; response email displayed only email adress again:
First Name :
Last Name :
Institution:
Address :
City :
State :
Zip :
Phone :
email : nikola.wenta@…
License : academic
Platform : intel
OS : win32
Version : Pre-Beta

Then I followed the activation link anyway and "finished registration". Result:
"License save results - Failure. The data presented is invalid."

comment:14 in reply to: ↑ 13 Changed 9 years ago by wenta

Replying to wenta:

Replying to bdubbs:

The blank info is an error. I see you made 24 attempts! The umlauts should have been accepted. It looks like they were in the DB.

I just tested the email and I got a full set of info in the email.

I deleted your registration where you used the googlemail account. Would you please test again (once) using that email and put in exactly one umlaut character. Let me know exactly what error messages you get, if any, and if the email still shows blank entries.

Be sure to run regedit and delete the HKEY_CURRENT_USER\Software\Ultrascan3 entry first.

I have used my googlemail adress and a umlaut in my last name; response email displayed only email adress again:
First Name :
Last Name :
Institution:
Address :
City :
State :
Zip :
Phone :
email : nikola.wenta@…
License : academic
Platform : intel
OS : win32
Version : Pre-Beta

Then I followed the activation link anyway and "finished registration". Result:
"License save results - Failure. The data presented is invalid."

I have tried it again with umlaut and my nottingham.ac.uk email, got the same error.
Then I tried again without umlaut and my nottingham.ac.uk email, this time success. Only response email is still blank.

comment:15 follow-up: Changed 9 years ago by bdubbs

  • Description modified (diff)

OK, I think I found at least one problem. I deleted your googlemail registration again. Please delete the HKEY and try again with the same single umlaut.

I think the email will be fixed, but I'm not sure the key generation will match the key checking in the case of umlauts, but lets tackle one thing at a time.

comment:16 in reply to: ↑ 15 ; follow-up: Changed 9 years ago by wenta

Replying to bdubbs:

OK, I think I found at least one problem. I deleted your googlemail registration again. Please delete the HKEY and try again with the same single umlaut.

I think the email will be fixed, but I'm not sure the key generation will match the key checking in the case of umlauts, but lets tackle one thing at a time.

Email looks complete now, but still the same error "License save results - Failure. The data presented is invalid." when "finish registration".
First Name : Nikola
Last Name : Wentä
Institution: UoN, School of Medical Sciences
Address : QMC
City : Nottingham
State : NON-US
Zip : NG7 2UH
Phone : 00441158230298
email : nikola.wenta@…
License : academic
Platform : intel
OS : win32
Version : Pre-Beta

comment:17 in reply to: ↑ 16 Changed 9 years ago by bdubbs

Replying to wenta:

Email looks complete now, but still the same error "License save results - Failure. The data presented is invalid." when "finish registration".

OK. That's one problem fixed. I'm pretty sure the other problem will need to be fixed in the US3 code. When I get that built, I'll send you a link for a new US3 version.

comment:18 follow-up: Changed 9 years ago by bdubbs

Please download http://bcf.uthscsa.edu/~dubbs/ultrascan3-1073-xpbeta-setup.exe
and install over the instance you have now. In addition to other fixes, this should allow non-ascii characters in the registration.

comment:19 in reply to: ↑ 18 ; follow-up: Changed 9 years ago by demeler

Replying to bdubbs:

Please download http://bcf.uthscsa.edu/~dubbs/ultrascan3-1073-xpbeta-setup.exe
and install over the instance you have now. In addition to other fixes, this should allow non-ascii characters in the registration.

Bruce: I tried it under XP-VMWare, and after deleting the registry entry I re-registered with a bunch of umlauts in my name, and everything worked well, and the umlauts were correctly displayed in the license program after reloading the license. It installed also without a problem over the previous installation. The only issue was that the e-mail did not preserve the umlaut's and instead display a question mark.

comment:20 in reply to: ↑ 19 Changed 9 years ago by wenta

Replying to demeler:

Replying to bdubbs:

Please download http://bcf.uthscsa.edu/~dubbs/ultrascan3-1073-xpbeta-setup.exe
and install over the instance you have now. In addition to other fixes, this should allow non-ascii characters in the registration.

Bruce: I tried it under XP-VMWare, and after deleting the registry entry I re-registered with a bunch of umlauts in my name, and everything worked well, and the umlauts were correctly displayed in the license program after reloading the license. It installed also without a problem over the previous installation. The only issue was that the e-mail did not preserve the umlaut's and instead display a question mark.

I have tried special characters ( , ' - ), and they are correctly displayed in the response email. Registration worked perfectly on my home computer, and I have it also running on my office computer now (with the same registration data - I have simply copied the registry key into my office computer's registry).
I guess, the use of umlauts will occur only in very rare cases, so I would say that a simple advice not to use them during the registration process might be sufficient. In my opinion, playing around with this last little detail now is not really necessary and can be done at a later stage.
Well done so far, Bruce! Let's see what other bugs I can create :-)

comment:21 follow-up: Changed 9 years ago by bdubbs

OK, I added:

Content-Type: text/plain; charset="UTF-8"

in the mail message. Try it again.

comment:22 in reply to: ↑ 21 Changed 9 years ago by demeler

  • Resolution set to fixed
  • Status changed from assigned to closed

Replying to bdubbs:

OK, I added:

Content-Type: text/plain; charset="UTF-8"

in the mail message. Try it again.

Yup, works now - I'll mark it as fixed:

First Name : üdfsgä
Last Name : Lödfg
Institution: afdgag
Address : sdfgsadfg
City : fdgsfdg
State : IL
Zip : 12345-4444
Phone : 123-222-3333
email : demeler@…
License : academic
Platform : intel
OS : win32
Version : 0.98

Note: See TracTickets for help on using tickets.