Opened 9 years ago

Closed 9 years ago

#174 closed enhancement (fixed)

Add experiment type to all_editedDataIDs API

Reported by: gegorbet Owned by: dzollars
Priority: normal Milestone: future
Component: ultrascan3 Version: 1.0
Keywords: review Cc:

Description

Add an experiment type field ("Velocity", "Equilibrium", "Other") as a return from the all_editedDataIDs stored procedure API. This would remove the need to call an extra get_experimentInfo in the course of building a list of edits that is filtered on experiment type. It would likely speed up the appearance of the filtered list.

Change History (3)

comment:1 Changed 9 years ago by dzollars

  • Keywords review added
  • Status changed from new to assigned

The experiment type has been added at the end of the list of items returned. Give it a try!

comment:2 Changed 9 years ago by gegorbet

Works beautifully! Use of this new field has been coded into the data loader, simplifying it and speeding the list display.

I would say that this ticket is fixed, but review by others should probably be performed.

comment:3 Changed 9 years ago by gegorbet

  • Resolution set to fixed
  • Status changed from assigned to closed

This change can only really be verified in code and not by a user. I have verified that it works as intended. It is being marked fixed.

Note: See TracTickets for help on using tickets.